path

path

[1] URL のうち、 scheme と fragment を除く部分を RFC 2396 は <scheme-specific-part> と呼んでいます。

仕様書

[5] URL の現行仕様である URL Standard にこれに相当する用語はありません。

歴史

[7] RFC 1630 は scheme-specific-part のことを path と呼んでいました。

[8] ただし BNF の生成規則では現在の path に近い使い方をしています。

[9] RFC 1738 と RFC 2396 は scheme-specific-part と呼んでいます。

実装

[10] Perl の URI.pm は scheme-specific part を返すメソッドを opaque と呼んでいます。

[11] RFC 2396 の <opaque_part> は階層型でない URL scheme における scheme-specific-part のことです。

関連

[3] ネットワークパス参照