OPES-Via:

OPES-System: ヘッダー、 OPES-Via: ヘッダー (HTTP)

[2] OPES-System: ヘッダーおよび OPES-Via: ヘッダーは、 OPES における追跡情報を含めるものです。

仕様書

構文

[3] 両ヘッダーの値は、0個以上の値のリスト (#) です >>1。

  1. ?
    1. 値
    2. *
      1. OWS
      2. ,
      3. OWS
      4. 値

[4] それぞれの値は、絶対URLの後に0個以上の引数を続けたものです。 ただし引数の前には ; が必要です。 >>1

[5] 絶対URL は RFC 2616 を通じて RFC 2396 absoluteURI の定義を、引数は RFC 2616 parameter の定義を参照しています >>1。またこの当時の構文の規定では空白を明記していませんが、 RFC 723x 世代でいう OWS が ; の前後に挿入できるものと推測されます。

  1. 絶対URL
  2. *
    1. OWS
    2. ;
    3. OWS
    4. 引数 (HTTP)

[6] 絶対URL には , や ; を含めることもできますが、区切り文字としてのこれらとどう区別するのかには言及がまったくありません。

文脈

[7] 両ヘッダーを応答で使った例が示されています >>1 が、 要求で使って良いか悪いかには言及がありません。他の RFC に OPES-System: ヘッダーを使った例があります >>11。

[8] 両ヘッダーは複数指定できます。しかし複数指定するのではなく、 1つにまとめるべきです。 >>1

[9] 任意選択の追跡情報に関するヘッダーはトレーラー部に含めて構いません。 必須の追跡情報はトレーラー部に含めてはなりません。 >>1

引数

[10] 構文上の引数は、追跡情報に含まれる引数を表すために使うようですが、 明確に説明されていません。例示では mode 引数が使われています。どのような引数を使って良いのか、 重複や順序の扱いなどは明記されていません。

歴史

[12] RFC 4229 によるIANA登録簿への登録にはタイミング的に間に合わなかったのでしょうが、 その後も現在に至るまでIANA登録簿には追加されていないようです。