variant

異体部分タグ (言語タグ)

[146] 異体 (variant) は、 他の部分タグによって表せない、言語や方言の “追加のよく認識された (well-recognized) バリエーション” を表します。 RFC 4646 2.2.5., RFC 5646 2.2.5.

[265] 言語タグ全体については、「言語タグ」の項をご覧ください。

仕様書

呼称

[268] Unicode言語識別子、Unicodeロケール識別子では unicode_variant_subtag、Unicode 言語異体符号 (language variant code) とも呼ばれています >>267。

順序と組み合わせ

[151] 異体は任意の個数、含めることができます。 RFC 4646 2.2.5., RFC 5646 2.2.5. ただし同じ異体を複数回使ってはなりません。 RFC 4646 4.1., RFC 5646 2.2.5.

[152] 異体の IANA への登録には Prefix を任意の個数指定することができます。 Prefix が指定されると、その異体は Prefix (のいずれか) で指定された部分タグがすべて前に含まれた状態でのみ使うべきです。 RFC 4646 2.2.5., RFC 5646 2.2.5.

[154] 例えば de-1996 のように使われる 1996 は、登録上 Prefix が de となっており、 de-1996 や de-CH-1996 のような言語タグは使って構いませんが、 ja-1996 のようには使うべきではありません。

[153] また異体によっては他の異体と同時に使えないことがあります。

[224] 例えば 1901 と 1996 を同時に使うべきではありません。 RFC 4646 2.2.5., RFC 5646 2.2.5.

[160] 異体が複数個含まれる時、 Prefix が指定されているものについては前の方に、 指定されていないものは後ろの方に並べるべきです。重要なものから前に並べますが、 順序が決まらない時はアルファベット順とします。 RFC 5646 4.1.

[225] 例えば、 en-scotland-fonipa は、

... なのでこれが正しい順序です。 RFC 5646 4.1.

[226] 例えば、 sl-IT-rozaj-biske-1994 は、

... なので、これが正しい順序です。 RFC 5646 4.1.

文脈

[147] IETF言語タグでは、 異体部分タグは言語部分タグ、 拡張言語部分タグ、 用字系部分タグ、 地域部分タグよりは後で、 拡張部分タグや私用部分タグよりは前になければなりません。 RFC 4646 2.2.5., RFC 5646 2.2.5.

[1] ScriptLangTag では、 地域部分タグの直後に0個以上書けます。 地域部分タグが省略されている場合は、 用字系部分タグの直後に当たります。

語彙

[150] 異体は5-8文字の英数字または最初が数字の4文字の英数字であり、 IANA に登録しなければなりません。他の部分タグとは違って、 ISO など特定の規格から半自動的に決まる文字列ではなく、 IANA への登録によって値と意味が決まります。 RFC 4646 2.2.5., RFC 5646 2.2.5.

[271] Unicode言語識別子、Unicodeロケール識別子では以前 IANA に登録されていない異体が使われていました。その一覧は >>270 にあります。

歴史

[156] 異体に相当する部分は RFC 3066 までは構文の制約 (8文字以下の英数字 RFC 3066 2.1) のもとで自由に使えるとされていました。

[2] RFC 4646 以降は IANA に登録しなければならないとされており、 実質的に非互換変更となっています。

[264] 3つ目以降の部分タグはすべて制限なく使えるようになっていたので、 私用や拡張に当たるものもなく、等しく追加の情報として扱われていました。