href

href 要素 (WebDAV)

[4] DAV: 名前空間の href 要素は、関係する URL を表すものです。

仕様書

構文

[3] href 要素の内容は、単純参照でなければなりません >>1。

文脈

[6] location 要素の子要素として使って、 Location: ヘッダーの値に相当する URL を表すことができます >>5。

[8] lockroot 要素の子要素として使って、 ロック根の URL を表すことができます >>7。

[10] locktoken 要素の子要素として使って、 ロックトークンの URL を表すことができます >>9。

[12] owner 要素の子要素として使って、 ロック作成者の URL を表すことができます >>11。

[14] response 要素の子要素として使って、 言及対象の資源の URL を表すことができます。 status 要素と併用する場合は1個以上、 propstat 要素と併用する場合は1個だけ使うことができます。 >>13

[16] 事前条件符号 lock-token-submitted の子要素として使って、 ロックされていて処理を失敗させた資源の URL を表すことができます >>15。

[17] 事前条件符号 no-conflicting-lock の子要素として使って、 衝突したロックのロック根の URL を表すことができます >>15。

[18] keepalive 要素でも使われていました。

歴史

[2] RFC 2518 (WebDAV) 12.3 href XML Element
Name
href
Namespace
DAV:
Purpose
Identifies the content of the element as a URI.
Value
URI ; See section 3.2.1 of [RFC2068]
目的
要素の内容を URI として識別します。

<!ELEMENT href (#PCDATA)>

[19] RFC 4437 - Web Distributed Authoring and Versioning (WebDAV) Redirect Reference Resources () <https://tools.ietf.org/html/rfc4437#section-10>