charset

charset 引数 (HTTP)

[158] 基本認証やダイジェスト認証の auth-param である charset は、 credentials で使うべき文字コードを表します。

仕様書

意味

[11] 基本認証では、利用者エージェントが credentials 送信時に使うべき文字コードのヒントを表します >>157。

[12] ダイジェスト認証では、サーバーが対応する文字コードを示します >>8。

値

[159] 値は、 UTF-8 のみ定義されています >>157, >>8。 他の値は予約されています >>157。 大文字・小文字不区別です >>157, >>13。

[3] その意味は純粋な UTF-8 とは異なります。 UTF-8 参照。

文脈

[4] 基本認証の challenge で指定できます >>157。 ダイジェスト認証の challenge には指定するべきです >>8, >>13。 credentials には指定できません。

[6] 必須ではありません >>157, >>8。

処理

[14] ダイジェスト認証の A1 や username で、ここで指定された文字コードを使います >>13。

[15] ダイジェスト認証では、 指定された値を理解できなければ、 要求を失敗とすることができます >>13。

歴史

[10] SASL ダイジェスト認証 (RFC 2831) で追加されました。

[1] 基本認証には RFC 7617 で新たに追加されました。

[2] 今後実装が広まるかどうかは未知数です。

[160] 意味的には accept-charset とするべきところですが、 SASL (RFC 2831) との整合性のため charset とされました >>157。

[9] HTTP ダイジェスト認証には RFC 7616 で追加されました。