Proxy-Connection

Proxy-Connection: ヘッダー (HTTP)

[3] Proxy-Connection: は、串とのHTTP接続に関するオプションを指定するものとして提案されていたヘッダーでした。

代替

[4] 似た役割は Connection: ヘッダーが果たしています。

仕様書

文脈

[5] クライアントは Proxy-Connection: ヘッダーを送信しないことを推奨 (encourage) します >>2。

[14] HTTP/2 では生成してはなりません >>18。

処理

[17] HTTP/1.0/HTTP/1.1 から HTTP/2 に変換する中間器は、 Connection: に Proxy-Connection が明示されているか否かに関わらず、 Proxy-Connection: ヘッダーがあれば削除するべきです >>18。

[15] Proxy-Connection: ヘッダーを含む HTTP/2 メッセージは奇形です >>18。

歴史

[8] Proxy-Connection: ヘッダーは HTTP/1.0 Keep-Alive のために使うことが提案されていましたが、機能しないことが分かり廃れました >>2。

[6] 持続的接続も参照。

[7] RFC 2068 や RFC 2616 はこのヘッダーに言及しておらず、RFC 4229 もIANA登録簿には追加しませんでした。 RFC 7230 が Keep-Alive の項で言及しましたが >>2, >>9、 IANA登録簿には追加されていません。

[11] Firefox や Safari も送信していました。 Firefox は送信をやめました >>10 が、 Squid との互換性の問題から CONNECT メソッドでは送信するよう戻されました >>12。

[13] HTTP-wg Archive: RE: Proxy-Connection header definition? ( ( 版)) <http://www.hpl.hp.com/personal/ange/archives/http-wg-archive/1213.html>