SIPにおけるURLの比較

SIPにおけるURLの比較

[1] SIP ではcontact URIの処理などのためにURLの比較の方法を定めています。

仕様書

定義

[7] >>6

歴史

[21] この URL の一致の定義は単独で章立てされたのは RFC 3261 からですが、仕組み上、同様の機能は存在していました。RFC 2543 ではポート番号の省略は 5060 番ポートと指定されたのと等価とされていましたが、 RFC 3261 では DNS SRV の利用を想定して等価とはしないと変更されています >>6。

[5063] 元々 IPアドレスの一致については規定が特にありませんでしたが、 RFC 5954 >>5061 で文字列表現ではなくバイナリー表現の一致とするとされています。

例

[22] 以下はそれぞれ等しいです >>6。

[23]

[24]

[25]

[26]

[5064] >>5061

[5065] >>5061

[5066] >>5061

[27] 以下は等しくありません >>6。

[28] user が違います。

[29] ポート番号が違います。

[30] transport が違います。

[31] ポート番号と transport が違います。

[32] header が違います。

[33] ドメイン名とIPアドレスは違います。

[34] 注意! 等しさは推移的ではありません。 >>6