Atomフィード

フィード (Atom)

Atom フィード文書

[16]

Atom フィード (Feed) 文書 (ぶんしょ) (Document) は、 Atomフィードの表現で、フィードに関するメタデータと、 それに関連付けられた記載の一部または全部を含みます。 その根は atom:feed 要素です。

出典: RFC 4287 <urn:ietf:rfc:4287> 2. Atom Document

[22] RFC 5005 におけるフィード文書 (feed document) は、 Atomフィード文書か、同様の syndication の実現値たる文書を指します。 フィード文書は任意の個数のエントリーで構成されます。 フィード文書は論理的フィードの完全な表現たることもあれば、そうでないこともあります。 >>23

[24] 同様の syndication というのは具体的には RSS のことを指しているようです。

MIME 型 application/atom+xml; type=feed

[17] RFC 4287 は Atomフィード文書の媒体型を application/atom+xml としています。

[18] しかし、 Atomエントリー文書と媒体型を共有していたので、 区別できた方がいい場面があることがわかったため、 新たに RFC 5023 で type 引数が定義されました。

[19] 仕様書: RFC 5023 - The Atom Publishing Protocol ( 版) <http://tools.ietf.org/html/rfc5023#section-12.1>

[20] type 引数の値 feed は、 Atomフィード文書であることを表します。その場合、 根要素は atom:feed でなければなりません。 AtomPub

[21] 現状、ほとんどの application/atom+xml 文書は type 引数のない Atomフィード文書であるとみられます。 そのためか、 RFC 5023 は Atomエントリー文書では type 引数を使うべきであるとする一方で、 Atomフィード文書については使っても構わないとするにとどめています。