ADLER32

ダイジェストアルゴリズム ADLER32 (HTTP)

[2] ダイジェストアルゴリズム ADLER32 は、 ZLIB の検査和を表します。

仕様書

意味

[3] ADLER32 は、 RFC 1950 ZLIB の32ビット検査和を1-8桁のASCII十六進数字を使って十六進表記したもので、先導0を使っても良い >>1 とされています。 十六進数字は大文字・小文字不区別です >>1。

歴史

[4] IANA登録簿に RFC 1590 と RFC 3309 を出典に Paul Millar により登録されています >>1。

[5] この値自体を規定する RFC は存在していないようです。