<html xmlns="http://www.w3.org/1999/xhtml"><head></head><body><p><anchor-end xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:" a0:anchor="1" xmlns:a0="urn:x-suika-fam-cx:markup:suikawiki:0:9:">[1]</anchor-end> This is a list of possible new features that might be incorporated into a future version of <anchor xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:">SWML</anchor>
(and implemented in <anchor xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:">Whatpm</anchor>/<anchor xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:">SuikaWiki4</anchor>).</p><section><h1>Citation/referencing</h1><p>Referencing another part of the document by name.</p><pre class="example code">foo bar [SOURCE].

[SOURCE] some document <anchor-external xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:" a0:resParameter="http://www.example.com/" xmlns:a0="urn:x-suika-fam-cx:markup:suikawiki:0:9:" a0:resScheme="URI">http://www.example.com/</anchor-external>.</pre><p>New block-level element for citation entries.</p><pre class="example code"> <strong>[</strong>REFS[
 - [SW09] SuikaWiki/0.9 specification <anchor-external xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:" a0:resParameter="http://..." xmlns:a0="urn:x-suika-fam-cx:markup:suikawiki:0:9:" a0:resScheme="URI">http://...</anchor-external>
 - [SW10] SuikaWiki/0.10 <anchor-external xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:" a0:resParameter="http://..." xmlns:a0="urn:x-suika-fam-cx:markup:suikawiki:0:9:" a0:resScheme="URI">http://...</anchor-external>
 - [SWML] SWML specification <anchor-external xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:" a0:resParameter="http://..." xmlns:a0="urn:x-suika-fam-cx:markup:suikawiki:0:9:" a0:resScheme="URI">http://...</anchor-external>
 ]REFS]</pre><p>Scope element for source</p><pre class="example code">  <strong>[</strong>SRCSCOPE[This feature is not supported in that implementation <strong>[</strong>SRC[SOMEDOCUMENT]].]]</pre></section><section><h1>WikiFormV2</h1><p>Trackback-like semi-automated cross-referencing between wiki pages</p><ed xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:10:">Need to survey <anchor xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:">SuikaWiki3</anchor>'s <anchor xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:">WikiForm</anchor> usage</ed></section><section><h1>Tables</h1><p>Table headers (HTML <code class="HTMLe" xml:lang="en"><anchor xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:">th</anchor></code> element)</p><p>Rowspans (HTML <code class="HTMLa" xml:lang="en"><anchor xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:">rowspan</anchor></code> attribute)</p><p>Multiline tables</p><pre class="example code"> ,,
 ,header1
 ,data1
 ,data1
 ,,
 ,header2
 ,data2
 ,data2,
 ,,</pre></section><section><h1>Paragraphs</h1><p>Breaks (HTML <code class="HTMLe" xml:lang="en"><anchor xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:">hr</anchor></code> element)</p><p>Example blocks</p><pre class="example code">  <strong>[</strong>EXAMPLE(html code)[
  &lt;h1&gt;ABC
  &lt;p&gt;abc
  ]EXMAPLE]</pre><p>with caption/credit/description?</p><p>Dialogs (HTML <code class="HTMLe" xml:lang="en"><anchor xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:">dialog</anchor></code> element)</p></section><section><h1>Sections</h1><p>Articles (HTML <code class="HTMLe" xml:lang="en"><anchor xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:">article</anchor></code> element)</p><p>Asides (HTML <code class="HTMLe" xml:lang="en"><anchor xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:">asides</anchor></code> element)</p><p>Addresses (HTML <code class="HTMLe" xml:lang="en"><anchor xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:">address</anchor></code> element)</p><pre class="example code">  <strong>[</strong>ARTICLE[
  [1] It's great!
  
  <strong>[</strong>ADDRESS[
  <strong>[</strong>FN[Foo-san]] <strong>[</strong>TIME[2008-12-12 23:44:11Z]]
  ]ADDRESS]
  ]ARTICLE]</pre><p>(would be generated by #comment form)</p></section><section><h1>Blockcodes</h1><p>Same as &quot;[&quot; &quot;PRE(code)[&quot;, but no white-space: pre.</p></section><section><h1>Inlines</h1><p>Marking (<anchor xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:">HTML</anchor> <code class="HTMLe" xml:lang="en"><anchor xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:">mark</anchor></code> element)</p><p>Footnotes</p><p>Escapes (for syntax characters such as <code class="char"><strong>[</strong></code>);
in <anchor xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:">SuikaWiki2</anchor> <code>__<strong>&amp;&amp;</strong>quot&amp;&amp;__</code> was converted to <code><anchor xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:">&quot;</anchor></code>
but it is stupid.</p></section><section><h1>RFC 2119 keywords</h1><pre class="example code">  <strong>[</strong>MUST[MUST]<strong>]</strong></pre><p>and as such.</p></section><section><h1>Explicit closing of a block</h1><p><anchor-end xmlns="urn:x-suika-fam-cx:markup:suikawiki:0:9:" a0:anchor="2" xmlns:a0="urn:x-suika-fam-cx:markup:suikawiki:0:9:">[2]</anchor-end> <pre class="example code">Not part of the list
- list item
- list item
&lt;!&gt;
not part of the list but belongs to the same block as the first line</pre></p></section><section><h1>Multilingual texts</h1><p>e.g. English text &amp; Japanese text</p></section><section><h1>Advanced diff markup</h1><p>e.g. RFC 1945/RFC 2068/RFC 2616 diffs with annotations</p></section><section><h1>See also paragraph</h1><p>e.g. <pre class="example code"><strong>[</strong>SEEALSO[
- <strong>[</strong>[page1]<strong>]</strong>
- <strong>[</strong>[page2]<strong>]</strong>
]<strong>]</strong></pre></p><p>or NAV?</p></section><section><h1>Rejected ideas</h1><p>Roundtrip for arbitrary XML markup / DOM tree
(difficult and dangerous)</p><p>Use other character than <code class="char"><strong>[</strong></code> for tags
(difficult because of backward compatibility issue)</p></section></body></html>